Удаление элементов из массива в цикле (удаление некоторых элементов из какой-либо коллекции элементов, обладающей свойством неявного сдвига элементов при удалении)

Способ 1:

КолвоЭлементовКоллекции = Коллекция.Количество(); 
Для ОбратныйИндекс = 1 По КолвоЭлементовКоллекции Цикл 
     ЭлементКоллекции = Коллекция[КолвоЭлементовКоллекции - ОбратныйИндекс]; 

     Если <Условие> Тогда 
          Коллекция.Удалить(ЭлементКоллекции); 
     КонецЕсли; 

КонецЦикла; 

Где Коллекция – обрабатываемая коллекция элементов.

Способ 2:

МассивКУдалению = Новый Массив();
Для Каждого эл из ТЗ Цикл 
     Если <Условие> Тогда 
          МассивКУдалению.Добавить(Эл); 
     КонецЕсли; 
КонецЦикла; 

Для Каждого эл из МассивКУдалению Цикл 
     ТЗ.Удалить(эл);
КонецЦикла;

Добавить комментарий

Ваш адрес email не будет опубликован.